
TalkMaster™ FOCUS 
Automation  

Events Reference Manual 





iii 

Table of Contents 
Getting Started .............................................................................................................................................. 1

Welcome To Events .................................................................................................................................. 1
Events Release Notes ............................................................................................................................... 1

Event Service ................................................................................................................................................ 3
Event Service Configuration ...................................................................................................................... 3
Event Service Configuration Menu ............................................................................................................ 4

Event Configuration Console ........................................................................................................................ 5
Event Creation ........................................................................................................................................... 5

Events Configuration Console Overview ............................................................................................... 5
Event Configuration Logon .................................................................................................................... 5
Application Layout .................................................................................................................................. 5
Event Creation Example ........................................................................................................................ 6
Triggers .................................................................................................................................................. 9
Timing .................................................................................................................................................. 11
Responses ........................................................................................................................................... 12

Menu Options .......................................................................................................................................... 15
Tools Menu .......................................................................................................................................... 15
Tools - Preferences .............................................................................................................................. 15
Tools - Create Event ............................................................................................................................ 16
Tools - Modify Event ............................................................................................................................ 16
Tools - Delete Event ............................................................................................................................ 16
Tools - Support Settings ...................................................................................................................... 16

Support Information ..................................................................................................................................... 19
Contacting Technical Support ................................................................................................................. 19
About Us .................................................................................................................................................. 19





1 

Getting Started 

Welcome To Events 
Welcome to the TalkMaster FOCUS Events feature of TalkMaster FOCUS Automation.
The Events feature of TalkMaster FOCUS Automation* provides the ability to monitor triggers from 
one or more IP Endpoints, the TalkMaster Server or based on Time of Day and then respond with an 
action or audio message to one or more IP Endpoints or respond with an Email.  The system also has 
the ability to alter the response based on the time and day of the week. 

 The Event Configuration Console is used to specify the triggers, timing and responses

 The Event Service monitors the triggers and timing and then sends the resulting actions or
audio response to the TalkMaster FOCUS Server in order to send the resulting audio to the
selected IP Enpdoints

The Event Service typically runs on the same machine as the TalkMaster FOCUS Server service. 
The Event Configuration Console can be run on any machine that can access the TalkMaster 
FOCUS Server. 

* TalkMaster FOCUS Automation is a separately licensed component of TalkMaster FOCUS

Events Release Notes 
V6.0.2 August 2019

 Updated the Triggers topic to note that the Incoming Call dialog can now be suppressed
when using the PTT(Call Button) Activation option

V5.1 November 2015 
 Initial Release
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Event Service 

Event Service Configuration 
The Event Service typically runs on the same machine as the TalkMaster FOCUS Server service. 
 The TalkMaster FOCUS Event Service must logon to the TalkMaster FOCUS Server in order to 
communicate with it, so an Operator UserID and Password needs to be supplied to it as a one-time 
setup.

To configure the logon information for the TalkMaster FOCUS Event Service, launch the Event 
Service Configuration console from the Windows Start menu All Programs --> TalkMaster 
FOCUS --> Automation --> Event Service Configuration. This console can also be used to display 
the current status of the service or to restart the service.

 Username / Password - Enter the Username and Password fields that will be used by
the TalkMaster FOCUS Event Service to login to the TalkMaster FOCUS Service.  The
Login ID must be defined in the Admin Console under the Operators tab

 IP Address - Enter the IP Address is the address of the TalkMaster FOCUS Server and the
associated Console Port as defined in the Admin Console.  The Console Port defaults to
3010

 Debug Tracking - This should be left unchecked unless instructed by Digital Acoustics
Technical Support

 Server Status - The Service Status area will display the current connection status of the
service

Save - Once the above changes have been made, press this button to apply the changes: 

 If the Server Status indicates that the TalkMaster FOCUS Event Service is running, but not
connected to the TalkMaster FOCUS Server, it will try to logon immediately and the TalkMaster
FOCUS Server Status should change to Connected to iEnterprise
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 If the Server Status indicates that the Alert Management Service is not running, then select
menu option Tools --> Restart Service to connect with the updated information

OK - Press this button to save the changes and exit 
Cancel - Press this button to ignore the unsaved changes and exit 

Event Service Configuration Menu 
File->Exit - Exits and saves the configuration information for the TalkMaster FOCUS Event Service

Tools->Restart Service - Restarts the TalkMaster FOCUS Event Service
Tools->Open Support Folder - Opens the support folder where the Debug Tracking Log is stored 

Help->About -  Displays the version information for the Event Service Configuration console 
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Event Configuration Console 

Event Creation 

Events Configuration Console Overview 
The Event Configuration Console provides the ability to setup Events that are monitored by the Event 
Service.  The Events follow a simple "IF THIS" - "THEN THAT" format and have the ability to specify 
a time based schedule that rule should apply to.  
Once the Events have been setup, the Event Configuration Console can be shut down.  The Event 
Service will communicate with the TalkMaster FOCUS Server service to monitor for the triggering 
events and  to respond to them. 

Event Configuration Logon
To start the Event Configuration Console, open the Windows Start menu --> All Programs -->
TalkMaster FOCUS --> Automation --> Event  Configuration Console.  The following Logon dialog will 
be presented:  

 Logon ID - Enter the Logon ID as configured in the Admin Console --> Operators tab
 Password -  Enter the associated password for the Logon ID
 Address - Enter the IP Address and port of the TalkMaster FOCUS Server.

In the Admin Console on the Operators tab, check the Allow Multiple Logons checkbox for 
the Operator ID that is used for administering TalkMaster instead of creating a separate UserID for 
each configuration console 

Application Layout 
The Event Configuration Console screen lists the Events that have been defined. 
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 Event Name - The name that has been assigned to this event

 Status - The status will be listed as Available or Unavailable. Unavailable means that the
event has been disabled by the operator

 Last Event - Displays the last date and time that the event occurred since the Event
Configuration Console was open

 Resp - The type of response that has been selected to respond to the event

Event Creation Example 
This is an example of creating an event that monitors an IP7's Sensor which is connected to a Door 
Switch on an Emergency Exit.  If the Sensor is activated at any time, a server based audio Message
will be sent to a Paging Group  where personnel will be monitoring the audio.  The audio Message
and the Paging Group must be created in the Admin Console prior to creating the Event. 

Enter an Event Name to uniquely identify this event 
Select the Sensor Activation trigger 
Select the Trigger source that will be monitored.  Click the down arrow to select the trigger from the 
list 
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Select the Timing when this event can occur.  Since this event will normally be monitored all of the 
time, select the default of All Days, All Day from the dropdown.   

Under Response, select Send Server Audio Message File from the <Select Response Action>
dropdown. 
Click the <Select Destination Device or Group>  dropdown to bring up the list of IP Endpoints and 
Paging Groups that have been defined in the Admin Console and select group:Emergency Door 
Opened.
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Press the Select button to bring up the list of audio Messages that have been defined in the Admin 
Console and select Emergency Exit Door Activated and then click the Save button 

The entire event can be temporarily disabled by checking the Disabled check box at the bottom. 
Click on the Save button at the bottom of the dialog to complete the event. 
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The completed event will appear in the main list box.  When the Event Configuration Console is 
running, the Last Event column is updated with the Date and Time an event occurs. 

Triggers 
Triggers are broken down into three components:

 Triggering Event

 Trigger Source

 Trigger Delay
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Triggering Events 
Triggering events and the associated "sources" of those triggers are broken down into three 
categories: 

 A single IP7 device or group of IP7 devices
 TalkMaster FOCUS Server Status

 Time of Day
IP7 Device / Group of IP7 Devices - The following triggers can be generated by a single IP7 or from 
any IP7 within a defined Paging Group.

 PTT(Call Button) Activation - Trigger an event when the IP7's TALK button is engaged (ie
TALK button pressed down).  The IP7 must be configured with the Call Button option
checked in the Admin Console.  Please note that this will also generate an Incoming Call for
the device.  To suppress the Incoming Call for this device, check the Don't Create Call
Queue Entries option in the Admin Console on the IP Endpoints --> General --> Options 3
tab

 PTT(Call Button) Deactivation - Trigger an event when the IP7's TALK button is released
(ie IP7 TALK button released and comes back up).  The IP7 must be configured with the Call
Button option checked in the Admin Console

 Sensor Activation - Trigger an event when the IP7's Sensor is activated.

 Sensor Deactivation - Trigger an event when the IP7's Sensor changes from activated to
deactivated

 Relay Activation - Trigger an event when the IP7's Relay activated.  An IP7's Relay can be
activated by:

 A Operator pressing the Door Open ICON in the Operator Console

 An IP7 device when it's Relay Mode is configured for Activate on PTT or Activate
On... MIC and/or Speaker

 The Event Service “Activate Relay” Response.

 Relay Deactivation - Trigger an event when the IP7's Relay changes from activated to
deactivated (refer to Relay Activation notes)

 Device Connection Status Change - This trigger is executed when the connection status of
the source IP7 or any IP7 in the specified group disconnects or reconnects with the
TalkMaster FOCUS Server

Server Connection Status Change - Trigger an event when the TalkMaster FOCUS server stops 
and starts.  The associated Trigger Source will change to Server
Time of Day - Trigger an event at the selected time of day 
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Trigger Sources 
The drop down list for the trigger source will automatically change based on the type of triggering 
event selected. 

 For IP7 Devices, the trigger source will list all IP7 Endpoints as well as any Paging Groups
that have been defined in the Admin Console

 For Server Connection Status Change, the trigger source will display a single option of
Server for the TalkMaster FOCUS Server

 For Time Of Day, the trigger source will change to a drop down of the time in 15 minute
intervals

Trigger Delay 
A delay can be included for the  PTT, Sensor and Relay activation triggers. If specified, this will delay 
the triggered response by the amount of time specified.  For instance, a five second delay might be 
introduced when a Relay is activated to give customers a chance to enter a building before playing a 
response of "Welcome to our Facility". 

Timing 
The Timing determines when the Event Service will monitor for an event trigger. 

The “All Days, All Day” schedule is available by default.  Other schedules can be created by pressing 
the New button.
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Each Schedule is a weekly schedule of up to three start and end times during the day when the 
schedule is in effect.  The start and end times can not overlap with other start and end times on the 
same day of the week. 

 Name - Enter a descriptive name for the schedule

 Days of the week - Click on the day of the week to set the

 Start Time 1 - Select the time (15 minute Intervals) when the schedule is in effect

 End Time 1 - Select the time (15 minute Intervals) when the schedule ends

 Start Time 2 - Select the time (15 minute Intervals) when the schedule is in effect

 End Time 2 - Select the time (15 minute Intervals) when the schedule ends

 Start Time 3 - Select the time (15 minute Intervals) when the schedule is in effect

 End Time 3 - Select the time (15 minute Intervals) when the schedule ends
Press Save to save the changes or Cancel to ignore the changes 

Responses 
Responses to triggers can be one of three categories: 

 Activate or Deactivate an IP7's Relay
 Send an Audio message using a pre-recorded file or a text file that will be converted to

speech

 Send an Email
The first two responses can be directed at a single or group of IP Endpoints.  The <Select 
Destination> dropdown will display the list of all IP7s and any Paging Groups that have been 
defined. 
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If the Send Server Audio Message File option is selected, use the Select button to specify the 
server based pre-recorded Message

If the Send TTS File from network drive option is selected, use the Select button to specify the 
location of a network location.  The text in the file will be converted to speech and played on the 
destination device(s). 

If the Send TTS Message option is selected, use the Select button to specify the text that will be 
converted to speech and played on the destination device(s). 
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If Send Email is specified, pressing the Select button opens a email dialog (please review the topic 
Tools-Preferences to setup the proper email UserID, Password and Port for the organization).  The 
email template can include variables that will automatically be replaced when the email is delivered, 
 A list of variables that can be used is shown at the end of this topic. 

Press the Save button at the dialog to save and exit. 

Email variables 

Merge Text Output

"%event.name%" Name of the Event

"%trigger.device.name%" Name of device to be triggered

"%trigger.group.name%" Name of group to be triggered

"%triggered.device.name%" Name of triggered device

"%triggered.device.mac%" MAC address of triggered device

"%triggered.device.address%" IP Address of triggered device

"%triggered.device.status%" Connection status of triggered device
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"%triggered.device.version%" Firmware Version of triggered device

"%response.device.name%" Name of device Responding

"%response.group.name%" Name of group responding

"%schedule.name%" Name of the Schedule

"%calendar.date%" Current Date

"%calendar.time%" Current Time

"%server.ip.address%" IP address of the TalkMaster FOCUS Server

"%server.status%" Status of the TalkMaster FOCUS server

Menu Options 

Tools Menu 
The Tools menu is used to create

Tools - Preferences 
General tab: 
This preference describes what should occur when the ‘X’ on the main console application is pressed, 
should it exit the console application, or just minimize to the system tray. 

Email tab:
If any event has a response specified as Send Email, this tab must be filled out with the appropriate 
information for the organization's email system.   
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After entering the information, the Test button can be used to verify the setup before saving and 
exiting. 

Tools - Create Event 
Selecting Tools->Create Event - Launches the dialog where a new event is created. For more 
details on Creating / Modifying an event, refer to the Triggers, Timing and Responses topics. 

Tools - Modify Event 
Tools-Modify Event - Launches the dialog to modify the event currently highlighted in the main 
screen. 
NOTE: This option will be disabled if no event has been highlighted. 

Tools - Delete Event 
Tools->Delete Event - Deletes the event that is highlighted in the main listbox. 
NOTE: This option will be disabled if no event has been highlighted. 

Tools - Support Settings 
Tools->Support Settings->Record Events to File - Select this option to begin recording information 
about the application to a log file.  The option is active when a checkmark appears next to it. 

Tools->Support Settings->Clear File - This option will clear the log in the Support Folder. 

Tools->Support Settings->Open Support Folder - This option will open the folder where the log is 
being stored. 
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Support Information 

Contacting Technical Support
For Information on contacting Technical Support, please visit our web site at: 
www.digitalacoustics.com

About Us 
Digital Acoustics, LLC 
www.digitalacoustics.com

Digital Acoustics®, TalkMaster FOCUS®, ii3®, IP7® and UBAM® are trademarks of Digital 
Acoustics LLC. All other marks used are properties of their respective owners. Digital Acoustics' 
product designs are packaged by leading manufacturers around the world.
© 2007 - 20  Digital Acoustics, LLC 
All Rights Reserved 
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Notes 
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